wiki:release0995

Version 0.9.9.5

Download

Changelog

  • added fckeditor 2.6.5 #150
  • added tinymce 3.2.7 #153
  • extend search to search for id of article #147
  • fixed bug with context menu that not check on type #151
  • add spanish translation #157
  • make different classnames and class files for extensions possible #158

Installation

  • Download Knowledgeroot
  • Unpack the Knowledgeroot package
  • Put the Knowledgeroot folder to your webspace
  • Start the Knowledgeroot install script with your browser: http://your.location/install.php
  • Enter all required informations and press install
  • After install check that the install.php and update.php are deleted
Notes
  • you can open the frontend with your browser: http://your.location/
  • you can open the admin interface with your browser: http://your.location/admin/
  • With the admin interface you can install extensions and configure knowledgeroot
  • the default login to frontend is user admin and password admin
  • SECURITY INFORMATION: install the extension libsecure to protect your installation against XSS attacks

Upgrade

Upgrade from 0.9.9.x

  • Make a backup of your data
  • Keep in mind what extra extensions you have installed!
  • Replace all files with the files in the archiv
  • Copy your existing configs from the conf folder to the new installation
  • Copy your extra extensions from system/extension/ to the new installation
  • Copy your existing upload folder to the new installation
  • Open the following location with your browser and run update: http://your.location/update.php
  • Delete install.php and update.php

Upgrade from 0.9.8.x

  • Make a backup of your data
  • Keep in mind what extra extensions you have installed!
  • Replace all files with the files in the archiv
  • Copy your existing configs from the conf folder to the new installation
  • Copy your extra extensions from system/extension/ to the new installation
  • Copy your existing upload folder to the new installation
  • Open the following location with your browser and run update: http://your.location/update.php
  • Delete install.php and update.php

Security

  • enable libsecurity

Support

Last modified 8 years ago Last modified on Oct 31, 2009, 8:42:28 PM